Добавляем документы для механизма «Ввод на основании».

Механизм «Ввод на основании» является весьма полезным и широко используется в различных конфигурациях 1С. Суть его состоит в том, что на основании одного документы (источника) создается другой документ (приемник) и открывается его форма, в которой заполняются табличные части и реквизиты, что существенно сокращает время работы.

К примеру в  «Бухгалтерия предприятия 2.0» существует множество документов, которые вводятся на основании других. Однако может быть такое, что некоторых  не хватает и нам необходимо добавить для ввода на основании. Не нужно ничего придумывать и писать горы кода. Все просто! Для этого нам необходимо перейти в режим «Конфигуратора», открываем нужный нам документ и переходим во вкладку «Ввод на основании».

После чего в таблице «Является основанием для:» жмем редактировать и добавляем необходимые нам документы. В частности мой бухгалтер просил, чтобы на основании документа «Поступление товаров и услуг» вводился документ «Передача товаров«. После проделанных манипуляций в модуле документа приемника в процедуре «ОбработкаЗаполнения» (если её нет, то создаем ) заполняем программно все необходимые поля и табличные части.

 

Процедура ОбработкаЗаполнения(Основание)

    Если ТипЗнч(Основание) = Тип(«ДокументСсылка.ПоступлениеТоваровУслуг») Тогда

            Организация = Основание.Организация;
            Склад = Основание.Склад;

            Для Каждого ТекущаяСтрока Из Основание.Товары Цикл
                      НоваяСтрока=Товары.Добавить();
                      НоваяСтрока.Количество = ТекущаяСтрока.Количество;
                      НоваяСтрока.Номенклатура = ТекущаяСтрока.Номенклатура;
                      НоваяСтрока.СчетУчета = ТекущаяСтрока .СчетУчета; 
          КонецЦикла;

КонецЕсли;

КонецПроцедуры

 

После чего обновляем конфигурацию  и запускаем информационную базу в режиме Предприятия.

 

Поделитесь своим мнением

Свежие записи
Советы и помощь программиста в 1с © 2018 ·   Войти   · Наверх