Конфигурация узла распределенной ИБ не соответствует ожидаемой

 

config wrong

Данный тип ошибки, скажу без преувеличения, является самой распространенной при работе с информационными базами данный 1С 8.2 и 1С 8.3. Чаще всего  возникает при некорректном завершении работы при обмене данными, а также может возникнуть на пустом месте при обмене.

Рассмотрим способ устранения ошибки.

  1. Создаем обязательно архивную копию базы с помощью выгрузки или копированием файла 1Cv8.cd.  Данная процедура должна войти в привычку у профессионального программиста.
  2.  Открываем конфигуратор центрального узла и сохраняем конфигурацию в файл («Конфигурация — Сохранить конфигурацию в файл»). сохраненный cf файл любыми способами доставляем к подчиненному узлу, где возникла ошибка.
  3. Заранее подготавливаем обработку со следующим тексом

Процедура КнопкаВыполнитьНажатие(Кнопка)
Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
СохранитьЗначение(«ВосстановитьЗначениеГлавногоУзлаВПодчиненном», ПланыОбмена.ГлавныйУзел());
ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
КонецЕсли;
Предупреждение(«Главный узел отключен»);
КонецПроцедуры

Процедура ОсновныеДействияФормыВключитьОбратно(Кнопка)
Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
ПланыОбмена.УстановитьГлавныйУзел(ВосстановитьЗначение(«ВосстановитьЗначениеГлавногоУзлаВПодчиненном»));
КонецЕсли;
Предупреждение(«Главный узел восстановлен»);
КонецПроцедуры

или скачиваем готовую Отключить (Включить) узел УРБД

Открываем в режиме «Предприятия» и используем ее.

4.  Открываем конфигуратор подчиненного узла и если  конфигурация находится на поддержке, то снимаем ее (Конфигурация — Поддержка — Настройки поддержки — Снять с

поддержки). Если нет, то пропускаем данный пункт.

support

5. Загружаем наш cf файл который был сохранен в центральном узле в текущую конфигурацию(«Конфигурация — Загрузить конфигурацию из файла…») и применяем обновление.

6. Возвращаемся в режим предприятия и применяем снова обработку, только теперь включаем обратно. Запускаем обмен и все будет работать!

Свежие записи
Советы и помощь программиста в 1с © 2018 ·   Войти   · Наверх