Недостаточно прав доступа: «У текущего пользователя нет доступных ролей, для запуска информационной базы».

not allowed

После создания новой информационной базы, в системе отсутствует по умолчанию какой-либо пользователь. В результате добавления администратором 1С новых пользователей, может появляться данная ошибка. Дело в том, что в конфигурациях БД существуют предопределенные базовые роли, это — роль «Бухгалтер » и роль «ПолныеПрава». Без них будет появляться такое информационное сообщение.

Если мы посмотрим глубже в программный код, то можем увидеть следующее в общем модуле Управление пользователями

Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт

Если НЕ РольДоступна(«ПолныеПрава») И НЕ РольДоступна(«Бухгалтер») Тогда
       Отказ = Истина;
       #Если Клиент Тогда
       Предупреждение(«У текущего пользователя нет доступных ролей, для запуска информационной базы.», 10, «Недостаточно прав доступа»);
     #КонецЕсли
КонецЕсли;

КонецПроцедуры

Таким образом система постоянно при запуске информационной базы проверяет роли у текущего пользователя. Для того чтобы исправить данную ситуацию необходимо в режиме конфигуратора зайти в  Администрирование — Пользователи назначить одну из базовых ролей во вкладке «Прочие».

users

Поделитесь своим мнением

Свежие записи
Советы и помощь программиста в 1с © 2018 ·   Войти   · Наверх